The Paradox of JavaScript

The problem is in ServerInfo.properties

I was just attempting to add an Apache Tomcat server to Eclipse Java EE IDE for Web Developers, Version: Mars.2, when I ran into a nasty snag: In the New Server dialog, the Next> button is not enabled. I also noticed an error in the top of the dialog: “The Apache Tomcat installation at this directory is version 8.5.15. A Tomcat 8.0 installation is expected“. Very annoying.

After some searching I found out that the problem is in ServerInfo.properties. The server.info= line needs to have the value: Apache Tomcat/8.0.0.

The Apache Tomcat installation at this directory is version 8.5.15 Tomcat 8.0 installation is expected

The above screenshot shows the issue. So if you run into this problem, this Stack Overflow article:  How to use Tomcat 8.5.x and TomEE 7.x with Eclipse? – Stack Overflow has the answer you need. Check out the answer by dexter-meyers. But also note the edit by informatik01. In short, you want to follow the detailed steps to patch catalina.jar, but you only need to change the version in the server.info= line.

For the complete answer to this issue, check out this Stack Overflow page:

https://stackoverflow.com/questions/37024876/how-to-use-tomcat-8-5-x-and-tomee-7-x-with-eclipse

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *